Resolved

The previous reported concern with email delivery in the EMEA region has been resolved. The service is fully restored and there is no longer an impact to customers. This incident is resolved.

Update

The EMEA email service remains fully operational and customers should see mail flowing normally.

We will continue to closely monitor the email service and will provide the next update on August 28, 2020 at 20:00 UTC or as new information becomes available.

Monitoring

On August 27, 2020, between 14:13 UTC and 14:23 UTC, customer connections to the EMEA email infrastructure may have received connection timeouts.

As of 14:23 UTC, the email service is fully operational and we continue to closely monitor the email traffic.

We will provide an update as soon as more information becomes available.

Began at:

Affected components