Messaging Security

Service availability and scheduled maintenance for Email Security.cloud and Messaging Gateway.

Email Delivery Delays in NAM Region
Incident Report for Messaging Security
Resolved
We have been monitoring the service for 12 hours and can confirm that service has been fully restored. This incident is now resolved.
Posted Jul 22, 2021 - 06:45 UTC
Update
We are no longer experiencing issues delivering email.

We are continuing to closely monitor the service. We will provide updates as new information becomes available.
Posted Jul 21, 2021 - 15:47 UTC
Monitoring
As of 15:26 UTC, the service has been restored. Some customers may continue to experience delays while the queued emails are processed.

We will continue to closely monitor the email service and will provide our next update as soon as more information becomes available.
Posted Jul 21, 2021 - 15:46 UTC
Update
We have increased the compute capacity and are seeing previously queued emails starting to deliver.

We will provide an update as soon as more information becomes available.
Posted Jul 21, 2021 - 15:05 UTC
Identified
We are aware of some customers provisioned on our NAM infrastructure experiencing delays sending and receiving emails. We have identified the cause of the issue and are currently working on mitigation.

Any emails queued on third party or customer MTAs will be delivered based on their respective retry schedules.

Please note that there is no impact to protection services, and all other aspects of our services remain functional.

We will provide an update as soon as more information becomes available.
Posted Jul 21, 2021 - 13:57 UTC
This incident affected: Email Security.cloud (Americas, Asia Pacific, Japan).