Messaging Security

Service availability and scheduled maintenance for Email Security.cloud and Messaging Gateway.

Echoworx Policy Based Encryption Email Delivery Issue
Incident Report for Messaging Security
Resolved
We have monitored the service and have not seen a re-occurrence of the email delivery issue. This incident is resolved.
Posted Oct 02, 2021 - 11:35 UTC
Monitoring
Email queues on the Broadcom infrastructure are back to normal levels. PBE customers will no longer experience email delivery issues.

We are closely monitoring the email service and will provide update as soon as more information becomes available.
Posted Oct 01, 2021 - 19:08 UTC
Update
The fix has propagated across all servers and PBE emails previously queued on Broadcom infrastructure have started delivering.

We will provide updates as new information becomes available.
Posted Oct 01, 2021 - 16:56 UTC
Update
The issue has been identified as an expired certificate which has now been replaced by Echoworx. Broadcom engineers are now trusting the Root certificate across our global infrastructure. This action is expected to take 1 hour. Policy Based Encryption customers may continue to experience email delivery issues.

We will provide updates as new information becomes available.
Posted Oct 01, 2021 - 15:37 UTC
Identified
We are continuing to closely work with Echoworx to address this issue. Please note that there is no impact to protection services, and all other aspects of our services remain functional.

We will provide updates as new information becomes available.
Posted Oct 01, 2021 - 14:19 UTC
Investigating
We are aware of Policy Based Encryption customers experiencing email delivery issues.

Our encryption provider Echoworx has identified the cause of this issue and currently working on a fix. Any emails queued on Broadcom infrastructure will be delivered once the issue is resolved.

We will provide updates as new information becomes available.
Posted Oct 01, 2021 - 13:33 UTC
This incident affected: Email Security.cloud (Americas, Asia Pacific, Europe, Middle East & Africa, Japan).